GRAND ASSIGNMENT - 1 Days Conversion

 Days Conversion

Given a number of days (N) as input, write a program to convert N to years (Y), weeks (W), and days (D).
Input

The input will be a single line containing a positive integer (N).
Output

The output should be a single line containing years, weeks, days values separated by spaces.
Explanation

For example, if the given number of days (N) is 1329.
1329 = 365*3 + 33*7 + 3
So the output is 3 years 33 weeks 3 days
Sample Input 1
1329
Sample Output 1
3 years 33 weeks 3 days
Sample Input 2
960
Sample Output 2
2 years 32 weeks 6 days



















N = int(input())
years = int(N/365)
remaining_days = N - (years * 365)  
weeks = int(remaining_days/7)
remaining_days = remaining_days-(weeks*7)  
days = remaining_days

print ((str(years) +" years ") +(str(weeks) + " weeks ")+(str(days) + " days"))

Comments

Popular posts from this blog

CODING ASSIGNMENT 3 Library Management

CODING PRACTICE 11 Music Page

CCBP Static Website Coding Assignment 2 Solution | Yoga Page